Creates a new set of parts out of the original elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void CreateParts( Document document, ICollection<ElementId> elementIds ) |
Visual Basic |
---|
Public Shared Sub CreateParts ( _ document As Document, _ elementIds As ICollection(Of ElementId) _ ) |
Visual C++ |
---|
public: static void CreateParts( Document^ document, ICollection<ElementId^>^ elementIds ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document containing the elements.
- elementIds
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements that parts will be created from.
Remarks
Parts will be added to the model after regeneration.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for creating parts. Elements should be of a valid category and the ids should be valid and should not already be divided into parts. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |