Sets Placement Number of an Adaptive Placement Point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void SetPlacementNumber( Document doc, ElementId refPointId, int placementNumber ) |
Visual Basic |
---|
Public Shared Sub SetPlacementNumber ( _ doc As Document, _ refPointId As ElementId, _ placementNumber As Integer _ ) |
Visual C++ |
---|
public: static void SetPlacementNumber( Document^ doc, ElementId^ refPointId, int placementNumber ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The Document
- refPointId
- Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
- placementNumber
- Type: System..::..Int32
Placement number of the Adaptive Placement Point.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. -or- The number placementNumber is out of range. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed. |