Indicates whether the specified point is within this face and outputs additional information about the point location.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool IsInside( UV point, out IntersectionResult result ) |
Visual Basic |
---|
Public Function IsInside ( _ point As UV, _ <OutAttribute> ByRef result As IntersectionResult _ ) As Boolean |
Visual C++ |
---|
public: bool IsInside( UV^ point, [OutAttribute] IntersectionResult^% result ) |
Parameters
- point
- Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.
- result
- Type: Autodesk.Revit.DB..::..IntersectionResult%
Provides more information only when the point is on the edge; otherwise, nullNothingnullptra null reference (Nothing in Visual Basic).
Return Value
True if within this face or on its boundary, otherwise False.
Remarks
The following is the meaning of the IntersectionResult members when the point is on the edge:
- EdgeObject is the edge that the point lies on
- EdgeParameter is the parameter of the point on the edge nearest to the UV point
- UV is the specified point