The dot product of this vector and the specified vector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double DotProduct( XYZ source ) |
Visual Basic |
---|
Public Function DotProduct ( _ source As XYZ _ ) As Double |
Visual C++ |
---|
public: double DotProduct( XYZ^ source ) |
Parameters
- source
- Type: Autodesk.Revit.DB..::..XYZ
The vector to multiply with this vector.
Return Value
The real number equal to the dot product.
Remarks
The dot product is the sum of the respective coordinates of the two vectors:
Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic). |