Move and resize a spiral or multiplanar instance to fit within a specified box.
The arguments are interpreted as an arbitrary rectangle in 3D with
vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the
rebar shape is inscribed in this rectangle following the procedure described
for the ScaleToBox method. The other end is placed in the parallel plane at
distance (center-to-center) given by the height argument, in the
direction of (xVec x yVec).
Note that spiral shapes interpret the input arguments using a different convention
than multiplanar shapes. For spiral shapes, the spiral start will be placed in
the rectangle defined by origin, xVec, yVec, and the end of the spiral will be
placed in the parallel plane. For multiplanar shapes, the rebar is placed with
its primary shape definition located in the parallel plane defined by the height
argument, and its connector segments extending in the direction opposite (xVec x yVec).
This method replaces ScaleToBoxForSpiral() from prior releases.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
public void ScaleToBoxFor3D(
XYZ origin,
XYZ xVec,
XYZ yVec,
double height
) |
Visual Basic |
---|
Public Sub ScaleToBoxFor3D ( _
origin As XYZ, _
xVec As XYZ, _
yVec As XYZ, _
height As Double _
) |
Visual C++ |
---|
public:
void ScaleToBoxFor3D(
XYZ^ origin,
XYZ^ xVec,
XYZ^ yVec,
double height
) |
Parameters
- origin
- Type: Autodesk.Revit.DB..::..XYZ
One corner of the rectangle.
- xVec
- Type: Autodesk.Revit.DB..::..XYZ
Vector representing the first edge of the rectangle. The length
must be positive.
- yVec
- Type: Autodesk.Revit.DB..::..XYZ
Vector representing the second edge of the rectangle. Must
be perpendicular to xVec.
- height
- Type: System..::..Double
New value for the Height or MultiplanarDepth property.
Exceptions
See Also