Constructs a new instance of a filter to match family instances of the given family symbol.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
Visual Basic |
---|
Public Sub New ( _
document As Document, _
familySymbolId As ElementId _
) |
Visual C++ |
---|
public:
FamilyInstanceFilter(
Document^ document,
ElementId^ familySymbolId
) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document. This requirement is unique to this filter and is needed to ensure the input
family symbol id is valid for the provided document. This ensures the most stability and
greatest performance for this filter.
- familySymbolId
- Type: Autodesk.Revit.DB..::..ElementId
The family symbol id.
Exceptions
See Also