Get a reference to the geometric point
associated with a grid node.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Reference GetGridNodeReference( GridNode gridNode ) |
Visual Basic |
---|
Public Function GetGridNodeReference ( _ gridNode As GridNode _ ) As Reference |
Visual C++ |
---|
public: Reference^ GetGridNodeReference( GridNode gridNode ) |
Parameters
- gridNode
- Type: Autodesk.Revit.DB..::..GridNode
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ]. |