Indicates whether the family can be converted to face host based.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static bool FamilyCanConvertToFaceHostBased(
Document document,
ElementId familyId
) |
Visual Basic |
---|
Public Shared Function FamilyCanConvertToFaceHostBased ( _
document As Document, _
familyId As ElementId _
) As Boolean |
Visual C++ |
---|
public:
static bool FamilyCanConvertToFaceHostBased(
Document^ document,
ElementId^ familyId
) |
Return Value
True if the family can be converted to face-based.
Otherwise false, which will be returned if there any family instances exist in the project, the family is already face-based, or the family does not have a host.
Also, false is returned if the family does not belong to one of the following categories:
- OST_CommunicationDevices
- OST_DataDevices
- OST_DuctTerminal
- OST_ElectricalEquipment
- OST_ElectricalFixtures
- OST_FireAlarmDevices
- OST_LightingDevices
- OST_LightingFixtures
- OST_MechanicalEquipment
- OST_NurseCallDevices
- OST_PlumbingFixtures
- OST_SecurityDevices
- OST_Sprinklers
- OST_TelephoneDevices
Exceptions
See Also