Gets the subelement referenced by a parent id and subelement id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public Subelement GetSubelement( ElementId id, int subId ) |
Visual Basic |
---|
Public Function GetSubelement ( _ id As ElementId, _ subId As Integer _ ) As Subelement |
Visual C++ |
---|
public: Subelement^ GetSubelement( ElementId^ id, int subId ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..ElementId
Id of the element.
- subId
- Type: System..::..Int32
Id of the sub element.
Return Value
The subelement referenced by the input argument.
Remarks
nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid element or subelement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |