Gets all the Assets of the specified type.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public IList<Asset> GetAssets( AssetType assetType ) |
Visual Basic |
---|
Public Function GetAssets ( _ assetType As AssetType _ ) As IList(Of Asset) |
Visual C++ |
---|
public: IList<Asset^>^ GetAssets( AssetType assetType ) |
Parameters
- assetType
- Type: Autodesk.Revit.DB.Visual..::..AssetType
The asset type.
Return Value
Returns an array of all the Assets within Revit of the specified type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |