Implement this method so that on successive invocations it will return distinct subsets of
points which meet the criterion.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
int ReadPoints( PointCloudFilter rFilter, ElementId viewId, IntPtr buffer, int nBufferSize ) |
Visual Basic |
---|
Function ReadPoints ( _ rFilter As PointCloudFilter, _ viewId As ElementId, _ buffer As IntPtr, _ nBufferSize As Integer _ ) As Integer |
Visual C++ |
---|
int ReadPoints( PointCloudFilter^ rFilter, ElementId^ viewId, IntPtr buffer, int nBufferSize ) |
Parameters
- rFilter
- Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter used to process cloud points and determine which ones lie with the target volume.
- viewId
- Type: Autodesk.Revit.DB..::..ElementId
The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.
- buffer
- Type: System..::..IntPtr
Memory buffer into which the points should be written. The buffer was allocated by Revit and it is guaranteed to be valid for the duration of the call.
- nBufferSize
- Type: System..::..Int32
The maximum number of CloudPoint objects that may be copied into the buffer.