Checks if given type is valid for this panel schedule template element.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool IsValidType( PanelScheduleType panelScheduleType ) |
Visual Basic |
---|
Public Shared Function IsValidType ( _ panelScheduleType As PanelScheduleType _ ) As Boolean |
Visual C++ |
---|
public: static bool IsValidType( PanelScheduleType panelScheduleType ) |
Parameters
- panelScheduleType
- Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleType
The given type to check.
Return Value
True if panel schedule template can have a type assigned and this type is valid for this element, false otherwise.
Remarks
A type is valid for a panel schedule template element if it is defined by the PanelScheduleType class.
Note: PanelScheduleType::Enum::Unknown is not a valid type, it is used for initializing the variable of
the PanelScheduleType::Enum.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |