Adds an external resource to the folder path by supplying the resource name, version and reference information.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public void AddResource(
string resourceName,
string version,
IDictionary<string, string> referenceInformation
) |
Visual Basic |
---|
Public Sub AddResource ( _
resourceName As String, _
version As String, _
referenceInformation As IDictionary(Of String, String) _
) |
Visual C++ |
---|
public:
void AddResource(
String^ resourceName,
String^ version,
IDictionary<String^, String^>^ referenceInformation
) |
Parameters
- resourceName
- Type: System..::..String
The unique short name of external resource.
- version
- Type: System..::..String
The version of external resource.
- referenceInformation
- Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The (String, String) map containing reference or lookup information that will
be stored in Revit.
Exceptions
See Also