Constructs a new instance of a class, with given or default values, to place a point on a curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public PointLocationOnCurve( PointOnCurveMeasurementType measType, double measValue, PointOnCurveMeasureFrom measFrom ) |
Visual Basic |
---|
Public Sub New ( _ measType As PointOnCurveMeasurementType, _ measValue As Double, _ measFrom As PointOnCurveMeasureFrom _ ) |
Visual C++ |
---|
public: PointLocationOnCurve( PointOnCurveMeasurementType measType, double measValue, PointOnCurveMeasureFrom measFrom ) |
Parameters
- measType
- Type: Autodesk.Revit.DB..::..PointOnCurveMeasurementType
- measValue
- Type: System..::..Double
- measFrom
- Type: Autodesk.Revit.DB..::..PointOnCurveMeasureFrom
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |