The color settings which are applied to a PointCloudInstance element, or one of its scans.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public class PointCloudColorSettings : IDisposable |
Visual Basic |
---|
Public Class PointCloudColorSettings _ Implements IDisposable |
Visual C++ |
---|
public ref class PointCloudColorSettings : IDisposable |
Remarks
For different color modes (PointCloudColorMode), the color settings mean different things:
- for single color, color1 means the display color
- for other modes (intensity, elevation), color1 and color2 form a gradient from min to max
- for no overrides and normals, color1 and color2 are not used
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointCloudColorSettings
Autodesk.Revit.DB.PointClouds..::..PointCloudColorSettings