Interface for external servers implementing pipe pressure drop calculation.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public interface IPipePressureDropServer : IExternalServer |
Visual Basic |
---|
Public Interface IPipePressureDropServer _ Inherits IExternalServer |
Visual C++ |
---|
public interface class IPipePressureDropServer : IExternalServer |
Remarks
A typical way to use the external server can be:
- Implement a server class that derives from this interface
- Create a new server object and register it with the service, see ExternalServiceRegistry.
- Assign server for the pipe pressure drop calculation in PipeSettings.