Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Curve AsCurveFollowingFace(
Face faceForDir
) |
Visual Basic |
---|
Public Function AsCurveFollowingFace ( _
faceForDir As Face _
) As Curve |
Visual C++ |
---|
public:
Curve^ AsCurveFollowingFace(
Face^ faceForDir
) |
Parameters
- faceForDir
- Type: Autodesk.Revit.DB..::..Face
Specifies the face, on which the curve will follow the topological direction of the edge.
Return Value
It can be an Arc, Line, or HermiteSpline.
Remarks
Exceptions
See Also