Adds Member Forces to element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SetMemberForces( bool start, XYZ force, XYZ moment ) |
Visual Basic |
---|
Public Sub SetMemberForces ( _ start As Boolean, _ force As XYZ, _ moment As XYZ _ ) |
Visual C++ |
---|
public: void SetMemberForces( bool start, XYZ^ force, XYZ^ moment ) |
Parameters
- start
- Type: System..::..Boolean
Member Forces position on analytical model stick element. True for start, false for end.
- force
- Type: Autodesk.Revit.DB..::..XYZ
The translational forces at specified position of the element. The x value of XYZ object represents force along x-axis of the analytical model coordinate system, y along y-axis, z along z-axis respectively.
- moment
- Type: Autodesk.Revit.DB..::..XYZ
The rotational forces at specified position of the element. The x value of XYZ object represents moment about x-axis of the analytical model coordinate system, y about y-axis, z about z-axis respectively.
Remarks
If element already have member forces defined for that end, newly provided values replace current one.
Member forces are strictly related with releases. This means that setting member forces values is reasonable only for directions that have releases set to false.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |