Gets the user-visible name for a spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static string GetLabelForSpec( ForgeTypeId specTypeId ) |
Visual Basic |
---|
Public Shared Function GetLabelForSpec ( _ specTypeId As ForgeTypeId _ ) As String |
Visual C++ |
---|
public: static String^ GetLabelForSpec( ForgeTypeId^ specTypeId ) |
Parameters
- specTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec to get the user-visible name.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Cannot find info for the spec. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |