Loads or reloads the link from its currently-stored location. If the link is an
external resource, Revit will contact the IExternalResourceServer to get the latest version
of the link.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019.2
Syntax
C# |
---|
public LinkLoadResult Reload() |
Visual Basic |
---|
Public Function Reload As LinkLoadResult |
Visual C++ |
---|
public: LinkLoadResult^ Reload() |
Return Value
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this TopographyLinkType" is in a read-only document. |