Deletes a performance adviser rule from the list of rules.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void DeleteRule( PerformanceAdviserRuleId id ) |
Visual Basic |
---|
Public Sub DeleteRule ( _ id As PerformanceAdviserRuleId _ ) |
Visual C++ |
---|
public: void DeleteRule( PerformanceAdviserRuleId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
An id of the rule to be deleted from the list of rules.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |