The storage type describes the type that is used internally within the parameter to store its value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public StorageType StorageType { get; } |
Visual Basic |
---|
Public ReadOnly Property StorageType As StorageType Get |
Visual C++ |
---|
public: property StorageType StorageType { StorageType get (); } |
Remarks
The property will return one of the following possibilities: String, Integer, Double
or ElementId. Based on the value of this property the correct access and set methods should be used
to retrieve and set the parameter's data value.