Defines the type of interactions a pane has with the active editor when it becomes active in the Revit UI.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Since: 2017
Syntax
C# |
---|
public enum EditorInteractionType |
Visual Basic |
---|
Public Enumeration EditorInteractionType |
Visual C++ |
---|
public enum class EditorInteractionType |
Members
Member name | Description |
---|---|
Dismiss | Dismiss the active editor during pane activation. This results in the current selection being cleared and the editor canceled. One example built-in dockable pane that uses this mode is the Revit Project Browser. |
KeepAlive | Keeps the active editor alive during pane activation. This results in the current selection being kept active and available to the pane. One example built-in dockable pane that uses this mode is the Revit Property Palette. |