Indicates whether this parameter should be hidden from the properties palette when it has no value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public bool HideWhenNoValue { get; set; } |
Visual Basic |
---|
Public Property HideWhenNoValue As Boolean Get Set |
Visual C++ |
---|
public: property bool HideWhenNoValue { bool get (); void set (bool value); } |
Field Value
If true, the parameter will be hidden from the properties palette when it has no value. If false, the parameter will always be shown in the properties palette, no matter if it has a value or not.
Remarks
Even when hidden, the parameter can still be accessed directly via the API.