Rotates a set of elements about the given axis and angle.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
public static void RotateElements(
Document document,
ICollection<ElementId> elementsToRotate,
Line axis,
double angle
) |
Visual Basic |
---|
Public Shared Sub RotateElements ( _
document As Document, _
elementsToRotate As ICollection(Of ElementId), _
axis As Line, _
angle As Double _
) |
Visual C++ |
---|
public:
static void RotateElements(
Document^ document,
ICollection<ElementId^>^ elementsToRotate,
Line^ axis,
double angle
) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
- elementsToRotate
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to rotate.
- axis
- Type: Autodesk.Revit.DB..::..Line
The axis of rotation.
- angle
- Type: System..::..Double
The angle of rotation in radians.
Exceptions
See Also