Creates a new SchedulableField.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public SchedulableField( ScheduleFieldType fieldType, ElementId parameterId ) |
Visual Basic |
---|
Public Sub New ( _ fieldType As ScheduleFieldType, _ parameterId As ElementId _ ) |
Visual C++ |
---|
public: SchedulableField( ScheduleFieldType fieldType, ElementId^ parameterId ) |
Parameters
- fieldType
- Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
- parameterId
- Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | fieldType is not a schedulable field type |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |