Creates empty analysis results primitive associated with a curve and a transform.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
Visual Basic |
---|
Public Function AddSpatialFieldPrimitive ( _
curve As Curve, _
trf As Transform _
) As Integer |
Visual C++ |
---|
public:
int AddSpatialFieldPrimitive(
Curve^ curve,
Transform^ trf
) |
Parameters
- curve
- Type: Autodesk.Revit.DB..::..Curve
Curve to be associated with the primitive.
%curve% does NOT correspond to actual Revit geometry, i.e. it cannot be associated with reference;
otherwise the other overload of the method must be used (taking "reference" as the input)
- trf
- Type: Autodesk.Revit.DB..::..Transform
Conformal Transform to be applied to %curve%.
Return Value
Unique index of primitive for future references
Exceptions
See Also