Creates a new ParameterFilterElement in the given document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2019
Syntax
Parameters
- aDocument
- Type: Autodesk.Revit.DB..::..Document
The document in which to create the ParameterFilterElement.
- name
- Type: System..::..String
The user-visible name for the new ParameterFilterElement.
- categories
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories for the new ParameterFilterElement.
- elementFilter
- Type: Autodesk.Revit.DB..::..ElementFilter
The rules for the new ParameterFilterElement, represented as an ElementFilter.
ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter
representing a Boolean combination of ElementParameterFilters. In addition, we check that
each ElementParameterFilter satisfies the following conditions:
Its array of FilterRules is not empty and contains:
- Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
- Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
- Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and
the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.
Return Value
A pointer to the new ParameterFilterElement.
Exceptions
See Also