Connects placeholders that looks like elbow connection.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool ConnectPipePlaceholdersAtElbow( Document document, Connector connector1, Connector connector2 ) |
Visual Basic |
---|
Public Shared Function ConnectPipePlaceholdersAtElbow ( _ document As Document, _ connector1 As Connector, _ connector2 As Connector _ ) As Boolean |
Visual C++ |
---|
public: static bool ConnectPipePlaceholdersAtElbow( Document^ document, Connector^ connector1, Connector^ connector2 ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- connector1
- Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to.
- connector2
- Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to.
Return Value
True if connection succeeds, false otherwise.
Remarks
The placeholders may have physical connection or may not connect at all.
In the latter case, the first one connects to the end of second one.
If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |