Returns the parameters that are not among the set of filterable
parameters common to the given categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
Visual Basic |
---|
Public Shared Function GetInapplicableParameters ( _
aDoc As Document, _
categories As ICollection(Of ElementId), _
parameters As IList(Of ElementId) _
) As IList(Of ElementId) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document containing the categories and parameters to query.
- categories
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories that define the set of possibly filterable parameters.
- parameters
- Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The parameters desired for use in a parameter filter.
Return Value
A list of parameters from the given array that are not valid
for use in a parameter filter with the given categories.
Exceptions
See Also