Retrieves the line weight assigned to the category for the given graphics style type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Nullable<int> GetLineWeight( GraphicsStyleType graphicsStyleType ) |
Visual Basic |
---|
Public Function GetLineWeight ( _ graphicsStyleType As GraphicsStyleType _ ) As Nullable(Of Integer) |
Visual C++ |
---|
public: Nullable<int> GetLineWeight( GraphicsStyleType graphicsStyleType ) |
Parameters
- graphicsStyleType
- Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range. |