Constructs an instance of ThermalAsset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ThermalAsset( string name, ThermalMaterialType materialType ) |
Visual Basic |
---|
Public Sub New ( _ name As String, _ materialType As ThermalMaterialType _ ) |
Visual C++ |
---|
public: ThermalAsset( String^ name, ThermalMaterialType materialType ) |
Parameters
- name
- Type: System..::..String
The name of the asset.
- materialType
- Type: Autodesk.Revit.DB..::..ThermalMaterialType
The type of thermal material that this asset will describe.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- name cannot include prohibited characters. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |