Id of the category that drives the default naming scheme for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public ElementId NamingCategoryId { get; set; }
Visual Basic
Public Property NamingCategoryId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ NamingCategoryId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException When setting this property: This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories.
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL

See Also