Sets a copy of the given ThermalAsset to be used in the PropertySetElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetThermalAsset( ThermalAsset thermalAsset ) |
Visual Basic |
---|
Public Sub SetThermalAsset ( _ thermalAsset As ThermalAsset _ ) |
Visual C++ |
---|
public: void SetThermalAsset( ThermalAsset^ thermalAsset ) |
Parameters
- thermalAsset
- Type: Autodesk.Revit.DB..::..ThermalAsset
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |