Inserts a IndexTriangle into the stream and associated buffer.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void AddTriangle( IndexTriangle triangle ) |
Visual Basic |
---|
Public Sub AddTriangle ( _ triangle As IndexTriangle _ ) |
Visual C++ |
---|
public: void AddTriangle( IndexTriangle^ triangle ) |
Parameters
- triangle
- Type: Autodesk.Revit.DB.DirectContext3D..::..IndexTriangle
The triangle to be inserted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space. |