Gets the value of a parameter from any element passed to getStringValue,
getDoubleValue, getIntegerValue, or getElementIdValue.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public class ParameterValueProvider : FilterableValueProvider |
Visual Basic |
---|
Public Class ParameterValueProvider _ Inherits FilterableValueProvider |
Visual C++ |
---|
public ref class ParameterValueProvider : public FilterableValueProvider |
Remarks
For any parameter, only one of isStringValueSupported, isDoubleValueSupported,
isIntegerValueSupported, isElementIdValueSupported will return true. No attempt
to convert between types is made. For example, calling getStringValue, passing
the identifier of a numeric-typed parameter will give an empty string. No
exception will be thrown, and ParameterValueProvider will not attempt to convert
the numeric value to a string.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..FilterableValueProvider
Autodesk.Revit.DB..::..ParameterValueProvider
Autodesk.Revit.DB..::..FilterableValueProvider
Autodesk.Revit.DB..::..ParameterValueProvider