Opens an IFC document from disk using default options.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Document OpenIFCDocument( string fileName ) |
Visual Basic |
---|
Public Function OpenIFCDocument ( _ fileName As String _ ) As Document |
Visual C++ |
---|
public: Document^ OpenIFCDocument( String^ fileName ) |
Parameters
- fileName
- Type: System..::..String
The IFC file to be opened.
Return Value
The newly created document containing the IFC file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is an empty string. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'fileName' -or- A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | If Revit is missing document templates or if the file cannot be opened. |