Gets the length of the rod's top extension into structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018

Syntax

C#
public double GetRodStructureExtension(
	int rodIndex
)
Visual Basic
Public Function GetRodStructureExtension ( _
	rodIndex As Integer _
) As Double
Visual C++
public:
double GetRodStructureExtension(
	int rodIndex
)

Parameters

rodIndex
Type: System..::..Int32
The rod index.

Return Value

returns the extension that will be applied if the rod is attached to structure.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.

See Also