Obtains the StructuralConnectionSettings object for the specified project document.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static StructuralConnectionSettings GetStructuralConnectionSettings( Document document ) |
Visual Basic |
---|
Public Shared Function GetStructuralConnectionSettings ( _ document As Document _ ) As StructuralConnectionSettings |
Visual C++ |
---|
public: static StructuralConnectionSettings^ GetStructuralConnectionSettings( Document^ document ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
A project document.
Return Value
The StructuralConnectionSettings object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |