Tests whether the given state is valid for the associated view and the context the view is currently in.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public bool IsValidState( PreviewFamilyVisibilityMode state ) |
Visual Basic |
---|
Public Function IsValidState ( _ state As PreviewFamilyVisibilityMode _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidState( PreviewFamilyVisibilityMode state ) |
Parameters
- state
- Type: Autodesk.Revit.DB..::..PreviewFamilyVisibilityMode
A state of the PreviewFamilyVisibilityMode
Return Value
Returns True if the state is applicable for the view; False otherwise.
Remarks
As long as the PreviewFamilyVisibility mode is available and enabled in the associated view,
the Off and On states are always valid. However, the Uncut state is only
valid in plan views and reflected ceilings.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |