The building type name.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public string BuildingTypeName { get; set; } |
Visual Basic |
---|
Public Property BuildingTypeName As String Get Set |
Visual C++ |
---|
public: property String^ BuildingTypeName { String^ get (); void set (String^ value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: name is an empty string or contains only whitespace. -or- When setting this property: name cannot include prohibited characters. -or- When setting this property: The given value for name is already in use as a building type name. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |