Gets the bearer extension. The method is applicable only for bearer hanger.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public double GetBearerExtension( int rodIndex ) |
Visual Basic |
---|
Public Function GetBearerExtension ( _ rodIndex As Integer _ ) As Double |
Visual C++ |
---|
public: double GetBearerExtension( int rodIndex ) |
Parameters
- rodIndex
- Type: System..::..Int32
The index of the rod.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The hanger is not a bearer hanger. |