Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool HasImageField() |
Visual Basic |
---|
Public Function HasImageField As Boolean |
Visual C++ |
---|
public: bool HasImageField() |
Return Value
True if the schedule has at least one image field showing at least one image, false otherwise.
Remarks
This method may return an incorrect value if the data of the schedule view is out of date. Check [!:IsDataOutOfData()],
and call RefreshData()()()() to ensure that the return value is correct.