Checks if this subelement have given parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public bool HasParameter( ElementId parameterId ) |
Visual Basic |
---|
Public Function HasParameter ( _ parameterId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool HasParameter( ElementId^ parameterId ) |
Parameters
- parameterId
- Type: Autodesk.Revit.DB..::..ElementId
Parameter id.
Return Value
True if %parameterId% identifies valid parameter of this subelement, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |