Retrieves a category object corresponding to a BuiltInCategory id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual Category this[ BuiltInCategory categoryId ] { get; } |
Visual Basic |
---|
Public Overridable ReadOnly Property Item ( _ categoryId As BuiltInCategory _ ) As Category Get |
Visual C++ |
---|
public: virtual property Category^ Item[BuiltInCategory categoryId] { Category^ get (BuiltInCategory categoryId); } |
Parameters
- categoryId
- Type: Autodesk.Revit.DB..::..BuiltInCategory
Remarks
Unlike the method that obtains categories by name, this routine will obtain
the handle even of built-in subcategories.
Since 2016 it is advised to use either [!:Autodesk::Revit::DB::Category::GetCategory(Document,BuiltInCategory)]
or [!:Autodesk::Revit::DB::Category::GetCategory(Document,ElementId)] method from Category class.