Sets orientation type of an Adaptive Placement Point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void SetPointOrientationType( Document doc, ElementId refPointId, AdaptivePointOrientationType orientationType ) |
Visual Basic |
---|
Public Shared Sub SetPointOrientationType ( _ doc As Document, _ refPointId As ElementId, _ orientationType As AdaptivePointOrientationType _ ) |
Visual C++ |
---|
public: static void SetPointOrientationType( Document^ doc, ElementId^ refPointId, AdaptivePointOrientationType orientationType ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The Document
- refPointId
- Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
- orientationType
- Type: Autodesk.Revit.DB..::..AdaptivePointOrientationType
Orientation type of the Adaptive Placement Point.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed. |