Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public ElementParameterFilter(
	IList<FilterRule> filterRules,
	bool inverted
)
Visual Basic
Public Sub New ( _
	filterRules As IList(Of FilterRule), _
	inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
	IList<FilterRule^>^ filterRules, 
	bool inverted
)

Parameters

filterRules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules applied to test if the element passes this filter.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not pass the filter rules.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also