Deletes hydraulically separated systems and merges the system components into the connected system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2019

Syntax

C#
public static void DeleteHydraulicSeparation(
	Document document,
	ISet<ElementId> pipeElementIds
)
Visual Basic
Public Shared Sub DeleteHydraulicSeparation ( _
	document As Document, _
	pipeElementIds As ISet(Of ElementId) _
)
Visual C++
public:
static void DeleteHydraulicSeparation(
	Document^ document, 
	ISet<ElementId^>^ pipeElementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document where the system is deleted.
pipeElementIds
Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The boundary pipe that separates the system. Multiple pipes are allowed to delete more than one separated systems.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException One or more elements is not a pipe. -or- One or more elements is not a valid loop boundary.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also