Returns appearance properties that override the preset appearance of the material.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public Asset GetAppearanceOverride() |
Visual Basic |
---|
Public Function GetAppearanceOverride As Asset |
Visual C++ |
---|
public: Asset^ GetAppearanceOverride() |
Return Value
An instance of a rendering material asset, of null if there is no override.
Remarks
The returned instance of an Asset is valid only if there is an overide, which happens
if there are decals applied to the face that has the base material. In such cases the
rendering engine takes the asset of the material and merges it with the decal,
which results to this override asset. If there are no decals, this instance is null
and the HasOverriddenAppearance returns False.