Checks that the building HVAC system falls within an appropriate range.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool CheckBuildingHVACSystem( gbXMLBuildingHVACSystem buildingHVACSystem ) |
Visual Basic |
---|
Public Shared Function CheckBuildingHVACSystem ( _ buildingHVACSystem As gbXMLBuildingHVACSystem _ ) As Boolean |
Visual C++ |
---|
public: static bool CheckBuildingHVACSystem( gbXMLBuildingHVACSystem buildingHVACSystem ) |
Parameters
- buildingHVACSystem
- Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingHVACSystem
The building HVAC system to be checked.
Return Value
True if the building HVAC system falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |